Trik Membuat Websites Intranet agar dapat di akses dari Internet (Webserver lokal di akses dari Internet dengan Mikrotik dan Speedy)

Posted: May 31, 2010 in Artikel IT, Tips & Trik, Artikel Nathan Gusti Ryan, GLOBAL INFO, Mikrotik, Networking, Posting Kang N4th4n, Tips & Trik Internet, Web Server XAMPP
Tags:

Penulis Artikel : Nathan Gusti Ryan

Berikut ini saya sharing sedikit pengalaman saya pribadi, Trik untuk membuat WebServer LOKAL kita ( WebServer Intranet ) agar dapat di akses dari Internet mengunakan MIKROTIK ROUTER dan Koneksi Telkom SPEEDY ataupun koneksi ISP yang lain. Jika sebelumnya saya telah sharing Trik Port Forwarding dari Modem ADSL Linksys ( tanpa Mikrotik ), maka kali ini kita akan membuat Mikrotik kita menjadi Pengendali WEBSERVER Lokal kita (bahkan beberapa webserver lokal sekaligus loh ).

http://thinkxfree.wordpress.com/2011/08/14/panduan-setting-port-forwarding-modem-adsl-agar-ip-public-speedy-kita-menjadi-ip-webserver

Oke, jika kita sudah mengunakan Mikrotik sebagai Router kita dan Mikrotik ini bisa diakses dengan IP Public yang telah kita miliki dari mana saja. Jika kita mengunakan SPEEDY maka kita dapat melakukan setting Mikrotik seperti pada tutorial ini :

http://thinkxfree.wordpress.com/2010/04/16/step-by-step-installasi-router-mikrotik-dgn-adsl-speedy

 

Selanjutnya pahami dengan baik konsep desainnya seperti contoh yang saya buat ini :

 

Layout_Desain_Network_with_Mikrotik_for_Server_and_LAN_WLAN

 

Setelah Mikrotik kita setting IP Public-nya maka seperti terlihat dibawah ini maka selanjutnya Mikrotik Router kita dapat difungsikan lebih lanjut termasuk untuk mengatur WebServer Local Intranet kita agar dapat di akses dari Internet. Wewww… asyik… bisa punya WebServer sendiri tanpa hosting dech…

Tahap untuk melakukan setting Port Forwarding pada Mikrotik Router adalah sebagai berikut :

Pertama : Masuk ke menu IP lalu pilih Services.

Kedua : Ubah Services WWW atau Services yang semula / umumnya digunakan untuk mengakses Mikrotik WebBox dari Port 80 ( default ) menjadi port yang anda inginkan, misalnya pada contoh ini saya gunakan Port 1007. Tujuannya agar Port 80 ini dapat difungsikan untuk WebServer Local Intranet kita.

Ketiga : Selanjutnya kita masuk ke menu IP lalu pilih Firewall.

Keempat :  Selanjutnya masuk ke menu NAT ( Network Address Transaltion ) lalu tambahkan sebuah NAT Rule ( klik sibol + )

Kelima : Sebelum kita masuk ke setting NAT Rule lebih lanjut, disini kita telah membuat Webserver Local pada IP Address 192.168.88.100. Perhatikan dan pahami dengan seksama tentang IP Address dan setting NAT karena disinilah letak keberhasilan Port Forwarding WebServer kita nanti.

Perhatikan juga status XAMPP ( Apache Webserver & MySQL Database Server ) sudah running dan Websites Local di IP 192.168.88.100 sudah bisa diakses dari jaringan lokal seperti gambar diatas ini.

Keenam : Dari menu Winbox ->  Firewall -> NAT -> lalu pada menu Tab GENERAL kita tambahkan New NAT Rule, pilih atau setting seperti menu dibawah ini :

  • Chain = dstnat (artinya : Destination NAT )
  • Dst Address = 125.164.75.150 ( artinya : IP Public yang diakses dari Internet )
  • Protocol = TCP(6) (artinya protocol yang digunakan untuk mengakses ke webserver kita adalah TCP )
  • Dst Port =80 ( artinya Port 80 digunakan untuk mengakses ke IP Public kita ).
  • In Interface = pppoe-out1 ( artinya : interface akses ke Internet mengunakan Speedy Dial Up PPPoE oleh Mikrotik, untuk anda, sesuaikan dengan interface yang anda gunakan ).

Selanjutnya pada menu Tab ACTION, pilih atau setting seperti menu dibawah ini :

  • Action = dst-nat ( artinya jika memenuhi kondisi seperti pada setting GENERAL maka akan di forward ke IP dibawah ini ).
  • To Addres = 192.168.88.100 ( artinya : IP ini adalah IP address alamat tujuan port forwarding jika ada yang mengakses IP Public 125.164.75.150 ini akan di arahkan ke IP Local 192.168.88.100.
  • To Port = 80 ( artinya : Port yang dituju pada IP Local WebServer 192.168.88.100 yaitu Port 80 ).

Ketujuh : Setelah setting diatas selesai maka kita cek akses dari luar ( dari Internet ) ke IP Public kita 125.164.75.150 ini, maka…. Taaaarrrraaaaa…

Lalu muncullah tampilah Websites daripada Webserver local 192.168.88.100.


CONTOH SELANJUTNYA ADALAH WEBSERVER KEDUA dengan IP Address Local-nya adalah 192.168.88.99 dengan tampilan seperti dibawah ini.

Oke lah kalo begitu kita mulai lagi, dari menu Winbox ->  Firewall -> NAT -> lalu pada menu Tab GENERAL kita tambahkan New NAT Rule, pilih atau setting seperti menu dibawah ini :

  • Chain = dstnat (artinya : Destination NAT )
  • Dst Address = 125.164.75.150 ( artinya : IP Public yang diakses dari Internet )
  • Protocol = TCP(6) (artinya protocol yang digunakan untuk mengakses ke webserver kita adalah TCP )
  • Dst Port =99 ( artinya Port 99 digunakan untuk mengakses ke IP Public kita, karena Port 80 sudah digunakan untuk websites contoh pertama ).
  • In Interface = pppoe-out1 ( artinya : interface akses ke Internet mengunakan Speedy Dial Up PPPoE oleh Mikrotik, untuk anda, sesuaikan dengan interface yang anda gunakan ).

Selanjutnya pada menu Tab ACTION, pilih atau setting seperti menu dibawah ini :

  • Action = dst-nat ( artinya jika memenuhi kondisi seperti pada setting GENERAL maka akan di forward ke IP dibawah ini ).
  • To Address = 192.168.88.99 ( artinya : IP ini adalah IP address alamat tujuan port forwarding jika ada yang mengakses IP Public 125.164.75.150 ini akan di arahkan ke IP Local 192.168.88.99.
  • To Port = 99 ( artinya : Port yang dituju pada IP Local 192.168.88.99 yaitu Port 99 ).

Setelah setting diatas selesai maka kita cek akses dari luar ( dari Internet ) ke IP Public kita 125.164.75.150:99 ( jangan lupa sekalian tulis Port nya seperti ini yach ), maka… Taaaarrrraaaaa…

Muncullah tampilah Websites daripada Webserver local 192.168.88.99.

Oke… tutorial ini sudah cukup jelas dapat silahkan dicoba pada Mikrotik anda sendiri. Jika masih belum berhasil, segera hubungi rumah sakit terdekat… Salam…

Comments
  1. teguh says:

    wah, keren om…
    tutorial nya mantap, patut untuk di coba…

  2. iyoeng says:

    wuiyh…bagus banget OM articelnya ..tapi saya mo nanya neyh ..bukannya ip yang di dapet dari speedy itu ip dynamic yang sewaktu-waktu bakalan berubah…

  3. abu adam says:

    keren om nathan n dipraktekan, ijin copas ilmunya

  4. Mulyadi says:

    Helpfull very much..
    Thank you tutorial nya..

  5. ibnuyusuf says:

    most powerful idea lah pkoknya mahhh,…
    heheheeee,,,,..
    thank’s tutornya om,. ^^,

  6. burhan says:

    Master….tanya nih..
    kenapa ketika sya masuk IP > Service >Por WWW sy ubah selain 80 jadinya malah tidak bisa di akses ya ip public via web,gmn??tp ketika sy kembalikan ke port 80,kmdian sy akses ip publik sy,webserver sy bisa jalan,kmudian sy masuk winbox dan sy ubah kembali port di IP Services mjd bukan 80,trus sy akses ip publik via web,kog malah eror y??
    sy ubah kembali mjd port 80,e e…malah yg taampil malah web nya mirotik…
    ada solusi kah???
    nuwun……

  7. ivhan says:

    wah sangat bermanfaat artikelnya, makasih dah share…

  8. HERY says:

    KEREN GAN ILMUNYA. LAIN WAKTU TAK PRAKTEKIN MASALAHNYA BELUM PUNYA SPEEDY

  9. Jefry says:

    Beruntung sekali saya baca posting ini
    terima kasih, izin membookmarknya dulu supaya saya tidakl lupa dengan postingan anda ni

  10. Sahruddin S says:

    Sangat Terima kasih, atas potingannya
    Karena Saya salah seorang yang lagi mencari postingan ini dan akan di terapkan di RB1100AH
    sekali lagi terima kasih

  11. Oncom says:

    dicoba sekali langsung berhasil. makasi banget om😀

  12. Arman says:

    mantap gan….tapi kalau sudah ada proxy apa gak ikut berubah juga setting proxy squidnya……maklum masih newbie ne gan…….

  13. Marjuki says:

    Tutorial yang udah lama kucari akhirnya ketemu juga. Makasih banyak semoga jadi amal ilmu yang pahalanya terus mengalir selama yang membaca mempraktekannya.

  14. dani says:

    Maknyus mas Ryan tune nya, tapi bagaimana kalau ip dari speedy nya dynamic, kalau ada scriptnya lumayan jg tuh mas, saya dah coba yg dari forum seperti ini

    :global currentIP1;
    :local pppoePtr [/ip address find interface=”pppoe-out1″];
    :local newIP [/ip address get $pppoePtr address];
    :local natPtr [/ip firewall nat find comment=”pppoe-out1″];
    :if ($newIP != $currentIP1) do={
    :log info “ip address $currentIP1 changed to $newIP”;
    :set currentIP1 $newIP;
    }
    /ip firewall nat set $natPtr dst-address=$currentIP1

    gak jalan mas ryan, dmn ya kesalahan nya, mohon direvisi, tks

  15. irvin says:

    Gan, postingannya keren abiz. sangat membantu untuk newbe…
    setting di atas t untuk modem adsl.

    jika kita pake isp yang dapet kabel langsung connect tanpa ada modem. jadi kita cman di kasih no ip. tu forward ke server gmana?
    jadi kalo pake adsl kita pppoe-out1, nah untuk yang tanpa pppoe-out1 itu gmana?

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s