XPS-Mikrotik-FreeDDNS

Penulis Artikel : Nathan Gusti Ryan

Berikut ini saya sharing Step By Step konfigurasi AutoUpdate IP Public Dynamic dengan FreeDDNS pada Mikrotik Router. Artikel semacam ini sebetulnya sudah banyak dibuat dan di sharing di Mikrotik Wikipedia, namun saya buat artikel ini untuk memudahkan pemahaman dan memudahkan dalam implementasi-nya.

Latar belakang pembuatan artikel ini adalah karena layanan internet dari Provider Telkom Speedy dan Provider First Media di Indonesia, dll hanya memberikan layanan IP Public Dynamic. Sedangkan dengan adanya fasilitas IP Public ini dapat memberikan kemudahan bagi pelanggan untuk memanfaatkan IP Public tersebut untuk berbagai hal fungsional yang lebih bermanfaat lagi.

Kegunaan atau pemanfaatan IP Public tersebut diantaranya  kita dapat :

  • Membuat WebServer sendiri,
  • Membuat FTP Server sendiri,
  • Membuat VPN Server sendiri,
  • Membuat IP PBX Server sendiri dan lain-lain .

Sehingga tidak perlu keluar biaya yang lebih banyak untuk layanan hosting. Serta dengan server sendiri ini kita bisa membuat layanan Unlimited bandwith / quota, layanan Webserver unlimited space dan unlimited resource, memudahkan installasi maupun konfigurasi security-nya ( karena bukan shared hosting), dll. Karena untuk hardware-nya kita bisa provide sendiri sesuai keinginan kita dan sesuai budget yang kita miliki.

So… apa saja langkah-langkah agar kita bisa membangun layanan server sendiri tersebut???

1. Kita memiliki layanan Internet dengan IP Public Dynamic ( Speedy, Fastnet, dll ) serta mengunakan Router Mikrotik ( RouterBoard Mikrotik, PC Router Mikrotik, VM Router Mikrotik, dll.

2. Selanjutnya kita melakukan Registrasi di websites : www.changeip.com

Change-IP-Free-DNS-001

3. Setelah melakukan registrasi, kita lakukan Login dan melakukan registrasi nama subdomain untuk menentukan layanan DDNS yang kita inginkan. Pada contoh ini saya memilih subdomain FreeDDNS.com, MyDDNS.com, DynDNSPro.com dengan nama subdomain Thinkxfree.

Change-IP-Free-DNS-002a

Change-IP-Free-DNS-002b

4. Selanjutnya kita klik menu DNS Manager. Dan akan terlihat sejumlah nama Subdomain yang telah kita register.

Change-IP-Free-DNS-002c

Change-IP-Free-DNS-003

6. Selanjutnya jika kita klik menu View Recent DDNS Updates maka akan terlihat IP Public yang sudah di register pada Subdomain tersebut. Nah, IP Public ini kita bisa ganti secara manual ataupun secara otomatis. Jika mau meng-update secara otomatis ada beberapa cara. Yaitu Update via Tools / software DNS Client Updater ataupun mengunakan update via Router.

Change-IP-Free-DNS-004

7. Untuk Update via Tools / software DNS Client Updater, kita bisa download software-nya seperti dibawah ini :

http://www.changeip.com/accounts/download

Change-IP-Free-DNS-005

8. Untuk Updater via router Mikrotik, caranya adalah :

  • Membuat Script HomingBeacon Updater dari menu System Script.
  • Membuat Secheduler yang kita set permenit ( atau sesuka anda ) untuk menjalankan Script HomingBeacon Updater.

9. Dari Mikrotik Winbox, Pilih menu System Script untuk membuat Script HomingBeacon Updater seperti gambar dibawah ini. Lalu kita klik Apply / OK.

Mikrotik-Change-IP-Dynamic-DNS-001

10. Selanjutnya dari menu System Secheduler kita buat sebuah sechedule baru yang kita set permenit ( atau sesuka anda ) untuk menjalankan Script HomingBeacon Updater yang telah kita buat tadi.

Mikrotik-Change-IP-Dynamic-DNS-002

11. Tentukan nama Sechedule dan interval jalannya Script. Lalu pada pilihan On Event, taruh nama Script yang sudah kita siapkan. Lalu kita klik OK / Apply.

Mikrotik-Change-IP-Dynamic-DNS-003

12. Dan selanjutnya kita kita hasilnya seperti gambar dibawah ini.

Mikrotik-Change-IP-Dynamic-DNS-004

13. Selanjutnya kita pantau di ChangeIP.com hasil perubahan dari mikrotik tersebut.

Mikrotik-Change-IP-Dynamic-DNS-005

14. Selanjutnya akan terlihat seperti gambar dibawah ini.

Mikrotik-Change-IP-Dynamic-DNS-006

15. Selanjutnya langsung kita test dengan mengakses WebFig via thinkxfree.freeddns.com seperti gambar di bawah ini.

Mikrotik-Change-IP-Dynamic-DNS-007

16. Lebih lanjut kita dapat mengakses VPN Server dari Mikrotik kita seperti gambar dibawah ini.

Mikrotik-Change-IP-Dynamic-DNS-009-Setting-VPN

17. Untuk memudahkan anda, silahkan COPY PASTE Script dibawah ini, mudah sekali bukan??? Selamat mencoba… :

# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
# EDIT KONFIGURASI SESUAI ACCOUNT ANDA
# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
:global ddnsuser “NathanGR”
:global ddnspass “Password”
:global ddnshost “thinkxfree.freeddns.com”
:global ddnsinterface “SPEEDY”
# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
# END OF USER DEFINED CONFIGURATION
# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

:global ddnssystem (“mt-” . [/system package get [/system package find name=system] version] )
:global ddnsip [ /ip address get [/ip address find interface=$ddnsinterface] address ]
:global ddnslastip

:if ([:len [/interface find name=$ddnsinterface]] = 0 ) do={ :log info “DDNS: Gak ada interface dengan nama $ddnsinterface, check konfigurasinya lagi Mas Bro.” }
:if ([ :typeof $ddnslastip ] = “nothing” ) do={ :global ddnslastip 0.0.0.0/0 }
:if ([ :typeof $ddnsip ] = “nothing” ) do={
:log info (“DDNS: Gak ada IP Address di ” . $ddnsinterface . “, check dong Mas Bro.”)
} else={

:if ($ddnsip != $ddnslastip) do={
:log info “DDNS: UPDATE Sukses Mas Bro!”
:log info [ :put [/tool dns-update name=$ddnshost address=[:pick $ddnsip 0 [:find $ddnsip “/”] ] key-name=$ddnsuser key=$ddnspass ] ]
:global ddnslastip $ddnsip
} else={
:log info “DDNS: Gak ada perubahan IP Public Mas Bro.”
}
}

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s