Cisco-Academy-XPS-Corporate-Network

Penulis artikel : Nathan Gusti Ryan

 

Pada tutorial ini kita akan membangun jaringan berskala Enterprise mengunakan Device Cisco Catalyst Switch yang mana didalam artikel ini meliputi : Konsep, Desain dan Simulasi Konfigurasi. Perhatikan dengan seksama dan pahami dengan baik Desain berikut ini :

XPS-Topology-Network-Cisco-VLAN-for-Corporate

Artikel ini berdasarkan real implementasi penulis, investasi networking yang dibutuhkan adalah :

– 1 unit Switch Cisco Catalyst Layer 3 ( C3650 harga Rp. 50 juta-an ).
– 4 unit Switch Cisco Catalyst Layer 2 ( C2960 harga 4 x Rp. 30 juta-an ).
– 8 unit SFP Transceiver Modules 1G / media untuk Backbone Fiber Optic ( harga 8 x Rp. 8 juta-an ).
– Alternatif penganti SFP Transceiver Modules bisa mengunakan Media Converter 1G ( harga 8 x Rp. 4 juta-an ).
Kabel Fiber Optic Single Mode, panjang secukupnya sesuai jarak antar gedung / antar  Switch ( harga US$ 4 – 5 /meter ).
– Tambahan : Wallmount Rack, FO Patch Panel, Cat6 Patch Panel, FO Patch Cord, dll.

Jika jarak antar Switch kurang dari 100 meter, bisa mengunakan kabel UTP Cat6. Untuk jarak lebih dari 100 meter, sebaiknya mengunakan kabel Fiber Optic. Kabel FO ada 1 kabel yang berisi 4 Core, 6 Core dan 8 Core. Satu Link membutuhkan 2 Core FO. Lalu berapa sich jarak kabel Fiber Optic itu? Perhatikan keterangan dibawah ini :

FO SINGLE MODE :
–> Data rates 10 Gbps dengan jarak > 80 km ( Standart ).
 
Kalo FO SINGLE MODE mengunakan Optical Amplifiers :
–> Data rates 10 Gbps dengan jarak > lebih dari 1000 Km.
–> Data rates 40 Gbps dengan jarak > jarak ratusan Km.
–> Data rates 100 Gbps dengan jarak kurang dari 10 Km.
 
FO MULTI MODE :
–> Data rates 40 Gbps sd 100 Gbps  dengan jarak > 125 m.
–> Data rates 10 Gbps dengan jarak > 300 m ( Standart ).
–> Data rates 10 Gbps dengan jarak > 550 m ( Standart ).
http://en.wikipedia.org/wiki/Single-mode_optical_fiber
http://en.wikipedia.org/wiki/Multi-mode_optical_fiber
http://www.cisco.com/c/en/us/products/interfaces-modules/100-gigabit-modules/index.html
http://www.cisco.com/c/en/us/products/interfaces-modules/transceiver-modules/index.html

Setelah paham dengan gambar desain diatas dan kebutuhan hardwre atau Active Device, kita akan melakukan konfigurasi dengan Simulasi mengunakan Cisco Packet Tracer versi 6 yang bisa di download link dibawah ini :

https://docs.google.com/uc?id=0B4CjGsNlfXWyRXUwSnNCT2pUT2M&export=download

Selanjutnya pada skenario konfigurasi-nya kita lanjutkan dengan tutorial berikut ini dengan hasil akhir screenshot ini :

SS-Network-Cisco-VLAN-for-Corporate-Paket-Tracer-001

Okey, kita lanjutkan dengan SKENARIO MEMBANGUN ENTERPRISE NETWORK CISCO :

=========================================
Pada suatu kantor / Instansi / perusahaan dengan kondisi Geografis memiliki 5 buah gedung. Sebuah gedung utama yang terdapat Ruang Server ( DataCenter ). Lalu 4 buah gedung lainnya yang berdiri sendiri. Pada kelima gedung ini terdapat user dari berbagai departemen ( Main Office, Server & IT, Accounting, Finance, Marketing ).
 
Perusahaan / Instansi ini akan membangun jaringan dengan mengunakan sebuah Switch Cisco Layer 3 Catalyst 3560 (24 port) dan 4 buah Switch Cisco Layer 2 Catalyst 2960 (24 port). Masing-masing gedung akan dipasang Switch Cisco Layer 2 Catalyst 2960, karena pada setiap gedung / setiap Switch ini ada departemen yang berbeda maka dibuatlah beberapa VLAN dalam satu Switch.
 
Okey, selanjutnya kita akan mendesain Enterprise Network ini dengan Cisco Device :
(1). Pada Cisco Layer 3 Catalyst 3560 (24 port) , port 1 – 4 digunakan sebagai BackBone antar Switch alias Port Trunk. Port 8 & Port 9 digunakan untuk 2 buah Server.
 
(2). Pada setiap Cisco Layer 2 Catalyst 2960 (24 port), port 1 digunakan sebagai BackBone dari Switch Layer 2 Catalyst 2960 ke Switch Layer 3 Catalyst 3560.
 
(3). Pada setiap Cisco Layer 2 Catalyst 2960 (24 port), port 2-10 digunakan untuk VLAN 11, port 11-15 digunakan untuk VLAN 12, port 16-20 digunakan untuk VLAN 13, port 21-24 digunakan untuk VLAN 14.
 
(4). Pada setiap Cisco Layer 2 Catalyst 2960 (24 port), port 2 dipasang sebuah PC Client dengan VLAN 11. Port 11 dipasang sebuah PC Client dengan VLAN 12. Port 16 dipasang sebuah PC Client dengan VLAN 13.
=========================================

=================================
[1] Switch Catalyst 3560 L3 ( VTP Server ) :
=================================

# VLAN List :
-11   SERVER
-12   ACCOUNTING
-13   FINANCE
-14   MARKETING
—— ————————– ——— ———————–
# Switch L3    Port Trunk / BackBone    Fa0/1   –  Fa0/4
#11   SERVER               Fa0/5   –  Fa0/10
#12   ACCOUNTING       Fa0/11 –  Fa0/15
#13   FINANCE             Fa0/16 –  Fa0/20
#14   MARKETING         Fa0/21 –  Fa0/24
—— ————————– ——— ———————-
Server01         IP : 192.168.11.8/24   Fa0/8
Server02         IP : 192.168.11.9/24   Fa0/9
—— ————————– ——— ———————-

==================================
[2] All Switch Catalyst 2960 L2 ( VTP Client ) :
==================================

VLAN Name                           Status   Ports
#Switch L2 Port Trunk / BackBone       Fa0/1
 
#11   SERVER                       active    Fa0/2 –  Fa0/10
IP : 192.168.11.xxx/24
 
#12   ACCOUNTING               active    Fa0/11 –  Fa0/15
IP : 192.168.12.xxx/24
 
#13   FINANCE                      active    Fa0/16 –  Fa0/20
IP : 192.168.13.xxx/24
 
#14   MARKETING                 active    Fa0/21 –  Fa0/24
IP : 192.168.14.xxx/24
=========================================
VLAN PC CLIENT :               IP Address       Switch        Port
PC01-VLAN11                     192.168.11.2    Switch01    Fa0/2
PC02-VLAN12                     192.168.12.2    Switch01    Fa0/11
PC03-VLAN13                     192.168.13.2    Switch01    Fa0/16
 
PC04-VLAN11                     192.168.11.3    Switch02    Fa0/2
PC05-VLAN12                     192.168.12.3    Switch02    Fa0/11
PC06-VLAN13                     192.168.13.3    Switch02    Fa0/16
 
PC07-VLAN11                     192.168.11.4    Switch03    Fa0/2
PC09-VLAN12                     192.168.12.4    Switch03    Fa0/11
PC08-VLAN13                     192.168.13.4    Switch03    Fa0/16
 
PC10-VLAN11                     192.168.11.5    Switch04    Fa0/2
PC11-VLAN12                     192.168.12.5    Switch04    Fa0/11
PC12-VLAN13                     192.168.13.5    Switch04    Fa0/16

=========================================

Okey, baca dengan seksama konsep diatas. Kesimpulan installasi hardware-nya adalah :

PC01, PC02, PC03 dipasang pada Switch L2 Pertama. PC04, PC05, PC06 dipasang pada Switch L2 Kedua. PC07, PC08, PC09 dipasang pada Switch L2 Ketiga.  PC10, PC11, PC12 dipasang pada Switch L2 Keempat.

atau :

Pada Switch L2 Pertama, dipasang PC01 (VLAN11 ), PC02 (VLAN12), PC03 (VLAN13). Pada Switch L2 Kedua dipasang PC04 (VLAN11 ), PC05 (VLAN12), PC06 (VLAN13). Pada Switch L2 Ketiga dipasang PC07 (VLAN11 ), PC08 (VLAN12), PC09 (VLAN13).  Pada Switch L2 Keempat dipasang PC10 (VLAN11 ), PC11 (VLAN12), PC12 (VLAN13).

NOTE :

Pada Switch L3 Cisco 3560 akan berfungsi sebagai VLAN Server atau VTP Server. VLAN List akan kita buat pada Switch Cisco 3560. Semua Switch L2 Cisco 2960 akan berfungsi sebagai VLAN Client atau VTP Client.

Okey, dari skenario diatas kita awali dengan Installasi Packet Tracer pada PC / Laptop kita. Lalu kita buat file baru dengan menambahkan device berupa :

(1). 1 buah Switch Layer 3 Cisco Catalyst 3560.
(2). 4 buah Switch Layer 2 Cisco Catalyst 2960.
(3). 2 buah Server.
(4). 1 buah Laptop Administrator.
(5). 12 buah PC Client.

Contohnya seperti Screenshot dibawah ini :

SS-Network-Cisco-VLAN-for-Corporate-Paket-Tracer-002

Sekarang kita lanjutkan pada konfigurasi pada Switch L3 Cisco 3560.

==================================
Setting awal pada Switch Layer3 – SW-3560-01
==================================

Cisco#
enable
config terminal
hostname SW-3560-01
enable secret cisco
enable password cisco
end

==================================
Setting VTP Server pada Switch Layer3 – SW-3560-01#
==================================

SW-3560-01#
enable
conf t
vtp mode server
vtp domain thinkxfree
end

=========
( setiap mengakhiri konfigurasi, tekan ctrl-z untuk menyimpan konfigurasi ).

==================================
Pada Switch Layer 3 – SW3650-01, berikan perintah untuk menampilkan VTP status :
==================================

SW-3560-01#
show vtp status

==================================
Membuat VLAN Member pada Switch Layer3 – SW-3560-01 :
==================================

SW-3560-01#
ena
conf t
vlan 11
name SERVER
exit
vlan 12
name ACCOUNTING
exit
vlan 13
name FINANCE
exit
vlan 14
name MARKETING
exit
end

==================================
Menampilkan VLAN Member pada Switch Layer3 – SW-3560-01 :
==================================

SW-3560-01#
show vlan

==================================
Memberi IP Address VLAN pada Switch Layer3 – SW-3560-01 :
==================================

SW-3560-01#
ena
conf t
interface vlan 1
ip address 192.168.1.1 255.255.255.0
exit
interface vlan 11
ip address 192.168.11.1 255.255.255.0
exit
interface vlan 12
ip address 192.168.12.1 255.255.255.0
exit
interface vlan 13
ip address 192.168.13.1 255.255.255.0
exit
interface vlan 14
ip address 192.168.14.1 255.255.255.0
exit

==================================
Konfigurasi Port Trunk / Backbone pada Switch Layer3 – SW-3560-01 :
==================================

SW-3560-01#
ena
conf t
interface fastEthernet 0/1
switchport mode trunk
switchport nonegotiate
switchport trunk allowed vlan 1-100
no shutdown

interface fastEthernet 0/2
switchport mode trunk
switchport nonegotiate
switchport trunk allowed vlan 1-100
no shutdown

interface fastEthernet 0/3
switchport mode trunk
switchport nonegotiate
switchport trunk allowed vlan 1-100
no shutdown

interface fastEthernet 0/4
switchport mode trunk
switchport nonegotiate
switchport trunk allowed vlan 1-100
no shutdown
end
==================================
3 PORT MODE INTERFACE Switch Cisco Catalyst :
==================================
switchport mode trunk -> port switch untuk BackBone Trunking.
switchport mode access -> port switch untuk akses PC Client.
switchport mode dynamic auto -> port switch otomatis mau client atau backbone.

==================================
Menampilkan Status Trunk interface pada Switch Layer3 – SW-3560-01 :
==================================

SW-3560-01#
show interfaces trunk

==================================
Menampilkan Status Trunk interface pada Switch Layer3 – SW-3560-01 :
==================================

SW-3560-01#
show interface f0/1 - 0/4
-------------------------
SW-3560-01#
show interface f0/1 switchport
show interface f0/2 switchport
show interface f0/3 switchport
show interface f0/4 switchport
-------------------------
SW-3560-01#
show interface trunk
Port Mode Encapsulation Status Native vlan
Fa0/1 on 802.1q trunking 1
Fa0/2 on 802.1q trunking 1
Fa0/3 on 802.1q trunking 1
Fa0/4 on 802.1q trunking 1

Port Vlans allowed on trunk
Fa0/1 1-100
Fa0/2 1-100
Fa0/3 1-100
Fa0/4 1-100

==================================
ASSIGN PORT 8-9 dan 5-7 ke VLAN 11, port 11-15 ke VLAN 12, port 16-20 ke VLAN 13, port 21-24 ke VLAN 14 pada Switch Layer3 – SW-3560-01 :
==================================

SW-3560-01#
ena
conf t
interface fastEthernet 0/8
switchport access vlan 11
exit
interface fastEthernet 0/9
switchport access vlan 11
exit
interface fastEthernet 0/10
switchport access vlan 11
exit
interface range fa0/5 - fa0/7
switchport access vlan 11
exit
interface range fa0/11 - fa0/15
switchport access vlan 12
exit
interface range fa0/16 - fa0/20
switchport access vlan 13
exit
interface range fa0/21 - fa0/24
switchport access vlan 14
exit

=================================
Okey, sampai disini kita telah selesai melakukan konfigurasi pada Switch L3 Cisco 3560. Selanjutnya kita lakukan konfigurasi pada Switch L2 Cisco 2960 :

==================================
Setting Switch Layer2 – SW-2960-01 s/d SW-2960-04 :
==================================

Cisco1#
enable
config terminal
hostname SW-2960-01
enable secret cisco
enable password cisco
Cisco2#
enable
config terminal
hostname SW-2960-02
enable secret cisco
enable password cisco
Cisco3#
enable
config terminal
hostname SW-2960-03
enable secret cisco
enable password cisco
Cisco4#
enable
config terminal
hostname SW-2960-04
enable secret cisco
enable password cisco

==================================
Setting VTP Client pada Switch Layer2 – SW-2960-01 s/d SW-2960-04 dan Port 0/1 sbg Port Trunk :
==================================

SW-2960-01 - 04#
ena
conf t
vtp mode client
vtp domain thinkxfree

interface fastEthernet 0/1
switchport mode trunk
switchport nonegotiate
switchport trunk allowed vlan 1-100
no shutdown
end

==================================
Menampilkan VLAN Member pada Switch Layer2 – SW-2960-01 s/d SW-2960-04 :
==================================

SW-2960-01 - SW-2960-04#
show vtp status
show vlan

==================================
Menampilkan Status / Info interface Trunk pada Switch Layer2 – SW-2960-01 s/d SW-2960-04 :
==================================

SW-2960-01 - SW-2960-04#
show interface trunk
Port    Mode Encapsulation Status Native vlan
Fa0/1  on      802.1q           trunking   1

Port Vlans allowed on trunk
Fa0/1 1-100

NOTE : Sampai disini jika perintah show vlan kita sudah dapat menampilkan VLAN List yang ada di Switch Layer3 Cisco 3560 berarti setting kita sudah benar. Namun jika tidak tampil VLAN List, maka cek lagi setting Port Trunking-nya.

==================================
ASSIGN PORT 2-10 ke VLAN 11, port 11-15 ke VLAN 12, port 16-20 ke VLAN 13, port 21-24 ke VLAN 14 pada Switch Layer2 – SW-2960-01 – 04 :
==================================

SW-2960-01 - SW-2960-04 #
ena
conf t
interface range fa0/2 - fa0/10
switchport access vlan 11
exit
interface range fa0/11 - fa0/15
switchport access vlan 12
exit
interface range fa0/16 - fa0/20
switchport access vlan 13
exit
interface range fa0/21 - fa0/24
switchport access vlan 14
exit

==================================
Pada kondisi saat ini dari perintah diatas ini kita sudah bisa ping antar PC dalam 1 VLAN yang sama. Tapi masih belum  bisa ping antar PC yang beda VLAN. Misalnya :

PC01 ( 192.168.11.2 di Switch01 ) bisa ping ke PC04 ( 192.168.11.3 di Switch02 ), ping ke PC07 ( 192.168.11.4 di Switch03 ), ping ke PC10 ( 192.168.11.5 di Switch04).

So… bagaimana agar antar VLAN bisa saling berkomunikasi? Bisa saling PING, bisa saling akses atau sharing data, dll… dll…? Jawabnya adalah kita harus melakukan Konfigurasi Routing EIGRP pada Switch Layer 3 Cisco 3560.

Agar PC yang beda VLAN ini bisa saling berkomunikasi alias bisa saling PING, maka yang harus kita lakukan adalah “Konfigurasi Routing di Switch Layer 3 Catalyst 3560”. Ini yang dinamakan INTER VLAN.

Dan disinilah tampak jelas kenapa pada jaringan VLAN butuh yang namanya SWITCH LAYER 3 atau bisa mengunakan ROUTER. Karena Inter VLAN ini butuh Routing IP yang beda segmen alias beda jaringan LAN.

Dan karena fungsi tersebut, SWITCH LAYER 3 disebut juga MULTI LAYER SWITCH. Diantaranya adalah Switch Layer 3 seri 3560, 3650, 3750, seri 4000 – 6000 – 7000, dll.

==================================
Konfigurasi Routing EIGRP di Switch Layer 3 Catalyst 3560 :
==================================

SW-3560-01#
conf t
ip routing
interface vlan 1
ip address 192.168.1.1 255.255.255.0
no shutdown
interface vlan 11
ip address 192.168.11.1 255.255.255.0
no shutdown
interface vlan 12
ip address 192.168.12.1 255.255.255.0
no shutdown
interface vlan 13
ip address 192.168.13.1 255.255.255.0
no shutdown
interface vlan 14
ip address 192.168.14.1 255.255.255.0
no shutdown

SW-3560-01#
conf t
ip routing
router eigrp 1
network 192.168.1.0
network 192.168.11.0
network 192.168.12.0
network 192.168.13.0
network 192.168.14.0
no auto-summary
end

==================================
Menampilkan konfigurasi Routing di Switch Layer 3 Catalyst 3650 :
==================================

SW-3560-01#
show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
 D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
 N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
 E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
 i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
 * - candidate default, U - per-user static route, o - ODR
 P - periodic downloaded static route
Gateway of last resort is not set
C    192.168.1.0/24 is directly connected, Vlan1
 C    192.168.11.0/24 is directly connected, Vlan11
 C    192.168.12.0/24 is directly connected, Vlan12
 C    192.168.13.0/24 is directly connected, Vlan13
 C    192.168.14.0/24 is directly connected, Vlan14

==================================

Okey… Finaly… test ping from PC-01 ( 192.168.11.2 ) :

==================================

PC> ipconfig
 IP Address......................: 192.168.11.3
 Subnet Mask.....................: 255.255.255.0
 Default Gateway.................: 192.168.11.1
PC> ping 192.168.11.4
 Pinging 192.168.11.4 with 32 bytes of data:
 Reply from 192.168.11.4: bytes=32 time=16ms TTL=128
 Reply from 192.168.11.4: bytes=32 time=20ms TTL=128
 Reply from 192.168.11.4: bytes=32 time=12ms TTL=128
 Reply from 192.168.11.4: bytes=32 time=10ms TTL=128
 Ping statistics for 192.168.11.4:
 Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
 Approximate round trip times in milli-seconds:
 Minimum = 10ms, Maximum = 20ms, Average = 14ms
PC> ping 192.168.12.4
 Pinging 192.168.12.4 with 32 bytes of data:
 Reply from 192.168.12.4: bytes=32 time=15ms TTL=127
 Reply from 192.168.12.4: bytes=32 time=17ms TTL=127
 Reply from 192.168.12.4: bytes=32 time=27ms TTL=127
 Reply from 192.168.12.4: bytes=32 time=9ms TTL=127
 Ping statistics for 192.168.12.4:
 Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
 Approximate round trip times in milli-seconds:
 Minimum = 9ms, Maximum = 27ms, Average = 17ms
PC> ping 192.168.13.4
 Pinging 192.168.13.4 with 32 bytes of data:
 Reply from 192.168.13.4: bytes=32 time=9ms TTL=127
 Reply from 192.168.13.4: bytes=32 time=9ms TTL=127
 Reply from 192.168.13.4: bytes=32 time=6ms TTL=127
 Reply from 192.168.13.4: bytes=32 time=8ms TTL=127
 Ping statistics for 192.168.13.4:
 Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
 Approximate round trip times in milli-seconds:
 Minimum = 6ms, Maximum = 9ms, Average = 8ms

Hasil Testing dapat dilihat seperti Screenshot dibawah ini :

SS-Network-Cisco-VLAN-for-Corporate-Paket-Tracer-003

Untuk VLAN 14, silahkan tambahkan beberapa PC pada keempat Switch L2 anda. ( Test Uji Nyali alias Uji G Level. hehehehe… ).

Okey… sampai disini semua konfigurasi kita telah selesai, jangan lupa untuk membuat konfigurasi ini permanent pada StartUp semua Cisco kita. Berikan perintah dibawah ini :

SW-3560-01# SW-2960-01 - SW-2960-4#
write memory
copy running-config startup-config

==================================

Okey… Maaf, artikel ini bukan artikel Copas, nantikan artikel selanjutnya Cisco Cloud Router on VMWare. Sampai disini tutorial ini semoga bermanfaat dan bila anda mengalami kesulitan atau menghadapi kendala, fellfree untuk kontak email : nathan.gusti.ryan@gmail.com

Pembahasan Tutorial Cisco Networking yang masih ingin penulis sharing diantaranya adalah Tentang Cisco Cloud Router, Teknik Port Agregation alias Port Load Balancing alias EtherChannel, dll.

Teknik Port Agregation alias Port Load Balancing alias EtherChannel mengijinkan 2 – 8 Link :

-> - Fast Ethernet (FE) = upto 1600 Mbps.
-> - Gigabit Ethernet (GE) = 16.000 Mbps.
-> - 10-Gigabit Ethernet (10GE) = 160.000 Mbps.

Selamat mencoba. Salam………….

 

Comments
  1. Selamat malam pak,saya ada kendala pada saat setting di sw L3 set mode trunk ada problem “SW-3560-01(config-if)#switchport mode trunk
    Command rejected: An interface whose trunk encapsulation is “Auto” can not be configured to “trunk” mode.”
    ini kenapa yah pak?

  2. momon says:

    sebelumnya coba tambahkan command dulu pak

    switchport trunk encapsulation dot1q

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s