Cisco-Academy-XPS-Corporate-Network

Penulis artikel : Nathan Gusti Ryan

Semua orang koq bilang Cisco itu sulit…!!! Padahal… Cisco itu ya emang sulit dan tidak manusiawi… Tapi dengan beberapa tutorial Cisco Networking saya membuatnya menjadi lebih asyik dan lebih manusiawi…

Pada tutorial ini kita akan melakukan Installasi dan Konfigurasi CISCO CLOUD ROUTER 1000v dengan VMWare Workstation 10 ( vRouter ). Dalam artikel ini meliputi : Konsep, Desain dan Konfigurasi. Perhatikan dengan seksama dan pahami dengan baik Desain berikut ini :

Cisco-Cloud-Router-Concept

Pada tutorial ini, silahkan di catat lebih dulu desain IP Address untuk Cisco Cloud Router 1000v kita nanti :

192.168.222.2     = IP Modem / Gateway Internet.
192.168.222.102   = IP Port 1 -> WAN Router CCR 1000v.
192.168.102.1     = IP Port 2 -> IP Gateway LAN segmen 192.168.102.xxx.
192.168.103.1     = IP Port 3 -> IP Gateway LAN segmen 192.168.103.xxx.
192.168.104.1     = IP Port 4 -> IP Gateway LAN segmen 192.168.104.xxx.

TAHAP PERSIAPAN MEMBUAT CISCO CLOUD ROUTER 1000v  @VMWare Workstation 10

Sebelum melakukan Installasi CISCO CLOUD ROUTER 1000v, silahkan download dulu materialnya / ISO Installer-nya di : http://software.cisco.com/download

atau di :

http://tinyurl.com/cisco-cloud-router-by-007
http://tinyurl.com/cisco-cloud-router-iso-by-007

 

Download-Cisco-Cloud-Router-1000v-001

Selanjutnya kita buat sebuah Virtual Machine dengan VMWare Workstation. Spesifikasi VM untuk CISCO CLOUD ROUTER 1000v
adalah : vRam minimal 2,5 GB, vHDD minimal 8 GB ( Thin Provisioning ), vCPU minimal 1 Core, vNIC minimal 2 buah ( untuk WAN dan LAN ). Boleh Mode NAT ataupun Bridge untuk vNIC WAN-nya dan boleh Bridge ataupun LAN Segmen untuk vNIC LAN ). Lihat contoh Screenshot dibawah ini :

Cisco-Cloud-Router-1000v-001

Tapi pada contoh artikel ini kita akan membuat 1 buah vNIC WAN mode Bridge, dan 3 buah vNIC dengan Mode LAN Segmen 1 – 4. Selanjutnya gunakan ISO CISCO CLOUD ROUTER 1000v untuk installasi awal.

Cisco-Cloud-Router-1000v-002

 TAHAP INSTALLASI CISCO CLOUD ROUTER 1000v :

1. Lakukan Power On pada VM CISCO CLOUD ROUTER 1000v  yang telah kita buat.

Cisco-Cloud-Router-1000v-003

3. Tunggu hingga proses installasi dari ISO Installer ke local harddisk VM. Setelah proses installasi selesai, CCR Installer akan melakukan auto restart VM.

Cisco-Cloud-Router-1000v-004

4. Saat tampilan pertama kali muncul, lakukan konfigurasi awal seperti gambar dibawah ini :

Cisco-Cloud-Router-1000v-005

5. Lakukan juga pada opsi konfigurasi selanjutnya seperti gambar dibawah ini :

Cisco-Cloud-Router-1000v-006

6. Setelah selesai maka CCR 1000v akan menampilkan konfigurasi lalu akan muncul 3 pilihan seperti gambar dibawah ini. Pilihlah 2 untuk menyimpan konfigurasi ke NVRAM.

Cisco-Cloud-Router-1000v-007

7. Selanjutnya akan muncul nama router kita, berikan perintah : enable lalu masukkan password yang telah kita buat sebelumnya.

Cisco-Cloud-Router-1000v-008

8. Selanjutnya berikan perintah : configure terminal  untuk melakukan konfigurasi interface Port 1 yang selanjutnya kita akan lakukan konfigurasi dengan lebih mudah mengunakan Hyper Terminal.

interface gigabitEthernet 1
ip address 192.168.222.102 255.255.255.0
ip nat outside
no shutdown
exit

Cisco-Cloud-Router-1000v-009

9. Selanjutnya kita buka aplikasi Hyper Terminal. Buka koneksi baru dengan IP Address : 192.168.222.102, Port : 23, Connect using : TCP/IP (Winsock).

Cisco-Cloud-Router-1000v-011

10. Selanjutnya akan muncul tampilan seperti dibawah ini. Masukkan password untuk akses terminal.

Cisco-Cloud-Router-1000v-012

11. Langkah selanjutnya yang akan kita lakukan seperti gambar dibawah ini adalah : melakukan konfigurasi IP Address Port 2, Port 3, Port 4, dan melakukan konfigurasi NAT Inside masing-masing Port.

interface gigabitEthernet 2
ip address 192.168.102.1 255.255.255.0
ip nat inside  
no shutdown
exit

interface gigabitEthernet 3
ip address 192.168.103.1 255.255.255.0
ip nat inside  
no shutdown
exit

interface gigabitEthernet 4
ip address 192.168.104.1 255.255.255.0
ip nat inside  
no shutdown
exit

Cisco-Cloud-Router-1000v-013

12. Langkah selanjutnya yang akan kita lakukan seperti gambar dibawah ini adalah :

Melakukan konfigurasi Permit access-list untuk client dengan koneksi Port 2, Port 3, Port 4.

access-list 1 permit 192.168.102.0 0.0.0.255
access-list 1 permit 192.168.103.0 0.0.0.255
access-list 1 permit 192.168.104.0 0.0.0.255

Melakukan konfigurasi Routing ke Port 1 WAN :

ip route 0.0.0.0 0.0.0.0 192.168.222.2
ip route 192.168.102.0 255.255.255.0 gigabitEthernet 2
ip nat inside source list 1 interface gigabitEthernet 1 overload

Melakukan konfigurasi DNS Server Google pada CCR 1000v kita :

ip name-server 8.8.8.8
ip name-server 8.8.4.4

Melakukan konfigurasi DHCP Server pada CCR 1000v kita :

ip dhcp excluded-address 192.168.102.100 192.168.102.200
ip dhcp pool LAN-POOL-1
network 192.168.102.0 255.255.255.0
default-router 192.168.102.1
dns-server 8.8.8.8
exit

Cisco-Cloud-Router-1000v-014

13. Langkah selanjutnya yang akan kita lakukan seperti gambar dibawah ini adalah :

– Melakukan konfigurasi Web Access pada CCR 1000v kita ( http & https ), termasuk konfigurasi authentikasi-nya:

ip http server
ip http secure-server

ip http authentication enable
ip http client username cisco
ip http client password cisco
exit
^Z

Cisco-Cloud-Router-1000v-015

14. Sampai disini konfigurasi pada CCR 1000v kita telah selesai. Tapi jangan lupa untuk menyimpan konfigurasi ke memory dan sekaligus kita copykan running-config ke startup-config agar waktu Router baru di hidupkan langsung aktif konfigurasi yang telah kita buat ini. Caranya dengan memberi perintah :

write memory
copy run start

Cisco-Cloud-Router-1000v-016

15. Selanjutnya kita akan melakukan pengecekan hasil konfigurasi CCR 1000v  kita dengan perintah dibawah ini :

show ip interface brief
show access-lists
show ip nat translations
Show ip route

Cisco-Cloud-Router-1000v-017

 

Cisco-Cloud-Router-1000v-018

16. Selanjutnya kita akan melakukan pengujian hasil konfigurasi CCR 1000v  kita dengan perintah PING ke beberapa target dibawah ini :

ping 192.168.102.1
ping 192.168.222.102
ping 192.168.222.2
ping 8.8.8.8
ping google.com
ping okezone.com

Cisco-Cloud-Router-1000v-019

17. Okey setelah tahap pengujian PING lancar semua, selanjutnya kita akan melakukan pengujian dengan mengunakan PC Client. Disini saya mengunakan OS Windows 7 pada sebuah Virtual Machine yang lain. Jangan lupa bahwa CCR 1000v  Port 1 vNIC di konfigurasi Mode Bridge atau NAT, lalu Port 2 vNIC di konfigurasi Mode LAN Segmen 1. Nah… VM Windows 7 ini Port vNIC di konfigurasi Mode LAN Segmen 1. ( manifestasi jaringan 1 segmen dengan Port 1 CCR 1000v ).

Cisco-Cloud-Router-1000v-020

18. Lakukan Power On VM Windows 7, lalu Cek IP Address DHCP sudah kita dapatkan dari CCR 1000v ( sebagaimana konfigurasi pada tahap 12 ).

Cisco-Cloud-Router-1000v-021

19. Selanjutnya dari VM Windows 7, kita akan melakukan pengujian dengan perintah PING ke beberapa target dibawah ini :

ping 192.168.102.1
ping 192.168.222.102
ping 8.8.8.8
ping google.com
ping 192.168.103.1
ping 192.168.104.1

Cisco-Cloud-Router-1000v-022

 

Cisco-Cloud-Router-1000v-023

20. Selanjutnya kita juga bisa melakukan akses maupun konfigurasi  CCR 1000v via WebBrowser :

Cisco-Cloud-Router-1000v-024

Okey… sampai disini tutorialnya telah selesai. Mudah sekali bukan???

Selamat mencoba…

Salam…

Comments
  1. Pak.link download iso nya gak bisa..bagaimana saya bisa mendapatkannya pak?

  2. Rizal says:

    pak, untuk step yang ke 9, mengapa pakai port 23 ?

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s